Microsoft Office
Excel 2016 for Windows
Advanced Functions & Modifying Spreadsheets
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>4</td>
</tr>
<tr>
<td>Learning Objectives</td>
<td>4</td>
</tr>
<tr>
<td>The IF Function</td>
<td>5</td>
</tr>
<tr>
<td>The PMT Function</td>
<td>8</td>
</tr>
<tr>
<td>Headers and Footers</td>
<td>11</td>
</tr>
<tr>
<td>Saving the Entire Workbook as an HTML File</td>
<td>12</td>
</tr>
<tr>
<td>Inserting a Hyperlink</td>
<td>14</td>
</tr>
<tr>
<td>Creating a hyperlink to an existing file</td>
<td>14</td>
</tr>
<tr>
<td>Creating a hyperlink to a web page</td>
<td>15</td>
</tr>
<tr>
<td>Using the Graphical Tools</td>
<td>17</td>
</tr>
<tr>
<td>Drawing Shapes</td>
<td>17</td>
</tr>
<tr>
<td>Modifying Shapes</td>
<td>18</td>
</tr>
<tr>
<td>Resizing Shapes</td>
<td>18</td>
</tr>
<tr>
<td>Reshaping</td>
<td>18</td>
</tr>
<tr>
<td>Adding a Shape Style</td>
<td>19</td>
</tr>
<tr>
<td>Quick Shape Formatting</td>
<td>20</td>
</tr>
<tr>
<td>Adding Fill Color</td>
<td>21</td>
</tr>
<tr>
<td>Changing the Outline of a Shape</td>
<td>21</td>
</tr>
<tr>
<td>Changing a Selected Shape</td>
<td>22</td>
</tr>
<tr>
<td>Adding Text to a Shape</td>
<td>23</td>
</tr>
<tr>
<td>Inserting Screenshots</td>
<td>23</td>
</tr>
<tr>
<td>Capturing and Inserting a Specific Area of the Screen</td>
<td>24</td>
</tr>
<tr>
<td>Additional Help</td>
<td>24</td>
</tr>
</tbody>
</table>
Introduction

The Excel 2016 Advanced Functions and Modifying Spreadsheets booklet provides the user with the necessary skills to create more detailed and extensive spreadsheets, and enhance their visual impact with charts and other graphic objects.

Learning Objectives

- Using the IF Function.
- Using the PMT Function.
- Working with Frequencies.
- Inserting Headers and Footers.
- Creating Hyperlinks.
- Use drawing objects to add visual appeal to spreadsheets.
- Insert screenshots into the spreadsheet.
The IF Function

The IF function is a useful tool that allows you to see if a certain condition in a spreadsheet is true or false. If a condition is true, the function will carry out one action. If the condition is false, it will carry out a different function. (e.g. If students have a test score above 75, then they will be marked as pass).

The syntax for the IF function is as follows: =IF (logical_test, value_if_true, value_if_false)

- Logical_test - a value or expression that is tested to see if it is true or false.
- Value_if_true - the value that is displayed if the logical_test is true.
- Value_if_false - the value that is displayed if the logical_test is false

The following example explains how to use the IF function. Cells A3 through A12 contain exam grades. We will use the IF function to create a formula in cells B3 through B12 that will indicate if the corresponding grade is a Pass or a Fail.

![Figure 1 - Grades Example](image)

1. Click on cell B3.
2. In the Formula Bar, click on Insert Function.

![Figure 2 - Insert Function](image)
3. The *Insert Function* window appears. In the *Search for a Function* field, type **IF**.

![Figure 3 - Search for Function](image)

4. Click **Go**.

![Figure 4 - Click Go](image)

5. The IF function will appear in the *Select a Function* results. Click the **IF** function.

![Figure 5 - Select a Function Field](image)

6. Click **OK**.
7. The *Function Arguments* window will open. In the *Logical_test* field, type **A3>=70** (See Figure 6).
8. In the *Value_if_true* field, type “**Pass**” (See Figure 6).
9. In the *Value_if_false* field, type “**Fail**” (See Figure 6).
10. Click **OK** (See Figure 6).

![Function Arguments](image)

**Figure 6 - Complete the IF Function Argument**

11. The word **Pass** should now appear in cell **B3**.

![Pass](image)

**Figure 7 - Logical Test**

12. Copy the formula in cell **B3** to cells **B4** through **B12** using Excel’s autofill feature.

![Exam Grades](image)

**Figure 8 – Use AutoFill to Copy the Function**

**Note:** To activate *AutoFill*, hover the mouse in the **lower-right corner** of a cell until it turns into a black crosshair. Then left-click and hold as you **drag your mouse** down to select the cells to copy the formula into. When you release, **Excel** will copy the formula into the selected cells.

**Note:** You can also type the formula out in the *Formula Bar* by starting with an equals sign (=), then typing out the function, followed by your formula [e.g. =IF(A3>=70,"Pass","Fail")].
The PMT Function

The Excel PMT (payment) function is an incredibly easy tool to use when calculating financial data. Assuming that payments are made consistently (repayment frequency and amount remaining constant) at a constant Interest rate, we can use the PMT function to calculate monthly repayments of loans.

The PMT function uses the following syntax: `=PMT(rate,nper,pv,[fv],[type])`
- **Rate** - the Interest rate per period.
- **Nper** - the number of periods.
- **Pv** - the present value or the amount the future payments are worth presently.
- **Fv** (optional) - The future value or cash balance that you want after the last payment is made.
- **Type** (optional)- when you wish to make the payments. The value 0 is for payments made at the end of the period. A value of 1 is for payments made at the beginning of the period. If you omit the type argument in the function, Excel assumes that the payment is to be made at the end of the period.

The following explains how to use the PMT Function to calculate the monthly payments of a 5-year loan worth $100,000, with an interest rate of 12%.

![Loan Payment Table](image)

1. In the Formula Bar, click on the Insert Function button.
2. In the *Search for a function* field, type **PMT**.

![Figure 11 - Search for a Function](image)

3. Click **Go**.

![Figure 12 - Click Go](image)

4. The PMT function will appear in the *Select a Function* results. Click the **PMT** function.

![Figure 13 - Select a Function](image)

5. Click **OK**.
6. The *Function Arguments* window will open.

7. In the *Rate* field, we are looking for the interest rate which in this example is 12%. We will take this interest rate of 12% and divide it by the number 12 (12 months in a year). To have excel calculate this value for us, we will type in \( \frac{12}{12} \) (See Figure 14).

8. In the *Nper* field, we are looking for the number of payments during the lifetime of this loan of 5 years. In the *Nper* field, type \( 5 \times 12 \) (where 12 is the number of months in the year) (See Figure 14).

9. In the *Pv* field (Present Value), enter the present value of the loan ($100,000) (See Figure 14).

10. Click **OK** (See Figure 14).

11. The **Monthly Payments** will appear in the spreadsheet.

![](image)

**Figure 14 - Complete the PMT Function Argument**

**Figure 15 - Monthly Payments**
Headers and Footers:

Headers and Footers are lines of information that will appear at the top or bottom (respectively) of every page. The following explains how to add Headers and Footers into your Excel workbook.

1. On the View tab, select Page Layout.

2. The Page Layout view will display. Click in the area marked Add header.

3. The header will be selected and show three sections. Click on the left, center, or right section to select it.

4. Type your text to enter the header.
5. To format the text, select the text and select your preferred formatting options from the Home tab.

![Editing Font](image)

**Figure 20 - Editing Font**

6. To leave Header/Footer editing and return to your document, click a cell within the spreadsheet.

### Saving the Entire Workbook as an HTML File

You can save your Excel workbooks, spreadsheets, and graphs as HTML files (Hypertext Markup Language) so that they can be viewed on the Internet. The following instructions explain how to save the entire work book as an HTML file:

1. On the Ribbon, click the File tab.
2. In the Backstage view, Click Save As.

![Save As](image)

**Figure 21 - Click Save As**

3. The Save As tab will open. Click Browse to select a location on your computer.

![Browse](image)

**Figure 22 - Click Browse**
4. The Save As window will open. Navigate to the location on your computer where you want to save your document.

5. In the File name field, enter a **file name** (See Figure 23).
6. From the Save as type drop-down menu, select **Web Page** (See Figure 23).
7. Click **Save** (See Figure 23).

![Figure 23 - Save as type](image)

8. If you receive a message indicating that some features might be lost if saved as a Web Page, click **yes** to keep using the Web Page format.

![Figure 24 - Use Web Page Format](image)

**Note**: You can also save the currently selected sheet in your workbook as an HTML file by selecting **Selection: Sheet** from the Save options that appear after choosing Web Page from the Save As Type.

![Figure 25 - Save Sheet as HTML](image)
Inserting a Hyperlink

Hyperlinks are colored and underlined text or graphics that you click to go to a file or a website. The following explains how to create hyperlinks to go to files and websites.

Creating a hyperlink to an existing file

As an example, we will create a link to another spreadsheet within our workbook. The following explains how to create a hyperlink to another spreadsheet:

1. On Sheet 1, type **Go to Sheet 2** in an empty cell.
2. Select the cell containing the text.

![Figure 26 - Go to Sheet 2](image)

3. From the Insert Tab, click **Hyperlink**.

![Figure 27 - Hyperlink](image)

4. The **Insert Hyperlink** window will appear. Click **Place in this document**.

![Figure 28 - Place in this document](image)
5. In the list under *Cell Reference*, click **Sheet 2**.

![Image of Cell Reference](image_url)

**Figure 29 - Cell Reference**

6. Click **OK**.

7. The hyperlink will be created and displayed in blue on your sheet.

![Image of Hyperlink Created](image_url)

**Figure 30 - Hyperlink Created**

---

**Creating a hyperlink to a web page**

The following explains how to create a hyperlink to a web page. As an example, we will create a hyperlink to the *Kennesaw State University* web site:

1. In an empty cell, type *Kennesaw State University*.
2. Select the cell containing the text.
3. From the **Insert Tab**, click **Hyperlink**.

![Image of Hyperlink](image_url)

**Figure 31 - Hyperlink**
4. The *Insert Hyperlink* window appears. Under *Link to:*, click *Existing file or Web page*.

![Figure 32 - Existing File or Web Page](image)

5. In the *Address* field, enter the web address for Kennesaw State University

![Figure 33 - Enter the Address](image)

6. Click **OK**.
7. The hyperlink to the Kennesaw State University webpage will be created.

**Note:** When you hold the mouse pointer over the text *Kennesaw State University*, the arrow will change to a pointing finger. This indicates that the text is now a hyperlink. If you click on the hyperlinked text, a browser will open on the computer. The browser will open to the Kennesaw State University website.

![Figure 34 – Hyperlink](image)
Using the Graphical Tools

You can use Excel’s graphical tools to enhance the look of a spreadsheet or chart, or make it more understandable. The graphical tools allow you to add shapes (such as arrows and lines) and text boxes.

Drawing Shapes

The following section describes how to draw shapes using Excel’s drawing tools:

1. On the Insert tab, click the Shapes tool.

2. The Shapes Gallery will appear. Click the shape that you want to draw in the spreadsheet.

3. Your mouse cursor will change to a crosshair and you are ready to draw the shape. Hold left-click and drag in your spreadsheet where you want the shape to go.

4. As your mouse moves over the spreadsheet, it will create the shape. Release the left mouse button when finished drawing your shape.
Modifying Shapes

Once a shape is placed on the spreadsheet, you can modify the shape in a number of ways, such as resizing, reshaping, adding fill and outline colors, adding shadows, and adding text.

Resizing Shapes

Shapes are resized in the same way as clip art and pictures. The following explains how to resize a shape:

1. Click on the shape that you wish to resize. Sizing handles will appear as circles around the shape.

2. Hover your mouse cursor over a sizing handle. The mouse pointer will change its appearance to a double-arrow to indicate which direction the shape will be resized.

3. Hold left-click and drag the mouse to increase and decrease the size of the shape.

4. Release the mouse button when you have adjusted the shape to a larger or smaller size.

Reshaping

Some shapes have yellow reshaping points that you can click and drag to alter a certain aspect of the shape, such as the arrow point in the arrow shape.
Adding a Shape Style

Shape styles are presets that will apply a specific format to your shape. The following explains how to add a shape style:

1. Click on the Shape so that it is selected.
2. In the Ribbon, click the Drawing Tools – Format tab.

![Figure 40 - Drawing Tools: Format Tab](image)

3. In the Shape Styles group, click the More button.

![Figure 41 - More Button](image)

4. The Shape Styles gallery will open. Click the Style of your choice.

![Figure 42 - Select the Style](image)

5. Your selected style will be applied to the shape.

![Figure 43 – Applied Shape Style](image)
Quick Shape Formatting

New in Excel 2016 are Quick Shape formats. This feature increases the number of default shape styles by introducing new “preset” styles grouping when accessing shape styles. To apply a quick shape format:

1. After drawing your shape, the Drawing Tools - Format tab will appear.
2. On the Drawing Tools - Format tab, click the drop-down arrow in the Shape Styles box.

3. A drop-down will appear displaying all styles. New preset styles can be found under the preset grouping.
Adding Fill Color

The following explains how to add a fill color to a shape:

1. **On the Drawing Tools – Format tab, under the Shape Styles group, click the drop-down arrow next to the Shape Fill icon.**

![Figure 46 - Shape Fill](image)

2. A list of colors will be displayed. Click the **color** of your choice.

![Figure 47 - Select your color of choice](image)

Changing the Outline of a Shape

The following explains how to change the outline of a shape:

1. **On the Drawing Tools – Format tab, under the Shape Styles group, click the drop-down arrow next to the Shape Outline icon.**

![Figure 48 - Shape Outline](image)
2. A list of colors will be displayed. Click the **outline color** of your choice.

![Select a Color](image)

*Figure 49 - Select a Color*

### Changing a Selected Shape

You can change an existing shape into a different one without having to delete the existing shape. The following explains how to change a shape:

1. On the *Drawing Tools – Format* tab, under the *Insert Shapes* group, click **Edit Shape**.

![Edit Shape Icon](image)

*Figure 50 - Edit Shape Icon*

2. A *drop-down menu* will appear. Click **Change Shape**.

![Change Shape](image)

*Figure 51 - Change Shape*

3. The *Shapes Gallery* will appear. Select the **new shape** to replace the existing one.
Adding Text to a Shape

Shapes are helpful in pointing out information on a spreadsheet, and they can also be used as a text box. To add text to a shape:

1. Select the shape you wish to add text to.
2. Begin typing your text. The text will appear within the shape. Text can be formatted just like regular text in the spreadsheet.

![Figure 52 - Text in the Shape](image)

Inserting Screenshots

You can also use Excel to grab a screenshot of an open window. The following describes how to capture and insert a screenshot from the Kennesaw State University website:

1. Navigate to the website you wish to take a screenshot of (e.g. www.kennesaw.edu).
2. In Excel, under the Insert tab, click screenshot.

![Figure 53 - Screenshot Tool](image)

3. The available windows drop-down will appear, displaying all windows currently open on your desktop. Click the image that you want to insert into your spreadsheet.

![Figure 54 - Select your image](image)

4. Your screenshot will be added into the spreadsheet. Here, you may resize and reposition your image to your preference.
Capturing and Inserting a Specific Area of the Screen

If you wish to grab a screenshot of a portion of an open window, you can use the *screen clipping* tool to make your selection. The following describes how to capture and insert a specific area of the screen:

1. Minimize all **windows** except for the one you wish to take a screenshot of.
2. Navigate to the **website** you wish to take a screenshot of (e.g. www.kennesaw.edu).
3. In *Excel*, under the **Insert** tab, click **screenshot**.

![Figure 55 – Screenshot Tool](image)

4. The **available windows** drop-down will appear. Click **Screen Clipping**.

![Figure 56 - Screen Clipping](image)

5. Your screen will turn gray and your mouse cursor will turn into a *crosshair*. Hold left-click and drag to **frame the area** of your screen that you want to capture.

6. Release the mouse button. The selected area that you captured will appear in your spreadsheet.

Additional Help

For additional support, please contact the KSU Service Desk:

**KSU Service Desk for Faculty & Staff**

- Phone: 470-578-6999
- Email: service@kennesaw.edu
- Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)

**KSU Student Helpdesk**

- Phone: 470-578-3555
- Email: studenthelpdesk@kennesaw.edu
- Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)