Creating a Website with Publisher 2013
# University Information Technology Services

## Creating a Website in Publisher 2013

### Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>4</td>
</tr>
<tr>
<td>Learning Objectives</td>
<td>4</td>
</tr>
<tr>
<td>Getting Started</td>
<td>5</td>
</tr>
<tr>
<td>Editing the Home Page</td>
<td>6</td>
</tr>
<tr>
<td>Editing Text</td>
<td>7</td>
</tr>
<tr>
<td>Editing and Inserting Graphics</td>
<td>8</td>
</tr>
<tr>
<td>.........................................................................................</td>
<td></td>
</tr>
<tr>
<td>Replacing an Image with an Image from the Internet</td>
<td>8</td>
</tr>
<tr>
<td>Replacing an Image with an Image File</td>
<td>9</td>
</tr>
<tr>
<td>Inserting a Table</td>
<td>10</td>
</tr>
<tr>
<td>Inserting a Hyperlink</td>
<td>12</td>
</tr>
<tr>
<td>.........................................................................................</td>
<td></td>
</tr>
<tr>
<td>Creating a Hotspot</td>
<td>13</td>
</tr>
<tr>
<td>Inserting Links within Your Site</td>
<td>15</td>
</tr>
<tr>
<td>Inserting Additional Pages</td>
<td>17</td>
</tr>
<tr>
<td>Deleting Entire Pages</td>
<td>17</td>
</tr>
<tr>
<td>Inserting Navigation Links</td>
<td>18</td>
</tr>
<tr>
<td>Running the Design Checker</td>
<td>19</td>
</tr>
<tr>
<td>Saving the Web Site</td>
<td>22</td>
</tr>
<tr>
<td>Publishing the Web Site with SSH – Secure Shell FTP Client</td>
<td>24</td>
</tr>
<tr>
<td>.........................................................................................</td>
<td></td>
</tr>
<tr>
<td>To access the Secure File Transfer Client on-campus</td>
<td>25</td>
</tr>
<tr>
<td>To Download the Secure File Transfer Client to a Personal Computer</td>
<td>25</td>
</tr>
<tr>
<td>To Use the Secure File Transfer Client</td>
<td>26</td>
</tr>
<tr>
<td>.........................................................................................</td>
<td></td>
</tr>
<tr>
<td>Download Files from the Server</td>
<td>31</td>
</tr>
<tr>
<td>Upload Files to the Server</td>
<td>32</td>
</tr>
<tr>
<td>Logging out of the Secure Shell FTP client</td>
<td>33</td>
</tr>
<tr>
<td>Additional Help</td>
<td>33</td>
</tr>
</tbody>
</table>
Introduction
Microsoft Publisher 2013 is a powerful tool that can help you create professional looking flyers, brochures, and other forms of print publications, but can also be used to create basic websites. The following guide will help to get you started with creating a website in Publisher 2013 and upload your website to KSU’s studentweb, or KSUweb server.

Learning Objectives
After completing the instructions in this booklet, you will be able to:

- Create a basic webpage
- Utilize available publisher templates
- Insert various objects into your webpage
- Create hyperlinks and navigation bars
- Download, install, and use the SSH – Secure Shell FTP Client
**Getting Started**

Publisher gives you a variety of web site design templates to choose from. A template contains color elements, graphics, text formatting, and placeholders for the pages that will make up the website. You can then modify the pages as you like. The following explains how to select a template:

1. Under the *File Tab, New section*, type *Web Site* in the *Search for templates* box (See Figure 1).

![Figure 1 - Getting Started](image1.png)

2. Select one of the *Office.com Templates* (the *Web site (Tabs design)* template has been selected for this example) (See Figure 2).

![Figure 2 - Selecting Templates](image2.png)
3. A confirmation window will appear. Click on Create to confirm (See Figure 3).

![Web Site (Tabs Design)](image)

**Figure 3 - Web Site (Tabs Design)**

**Editing the Home Page**

The Publisher window now displays your home page based on the design template selected. The template contains placeholder text and images which can be replaced by your own text, and images of your choice. This will be the first page of your Web site that visitors will see.

On this page, explain your site’s purpose, content, and layout. Include tips on how to move through your site and where to find key information. Change the pictures to your own pictures. These steps will be explained in the sections *Editing Text* and *Editing and Inserting Graphics*.

**Note:** The *Page Navigation Pane* contains various pages that you will use to identify your web site’s function and purpose. You can move to a page by clicking on it (See Figure 4).

![Page Navigation](image)

**Figure 4 - Page Navigation**
**Editing Text**

The following explains how to edit text within your website:

1. Click the *heading area* and type in the *heading* that you want to use (See Figure 5).
2. Click in the *text area* and type *introductory information* about your website (See Figure 5).
3. Click in any other areas *containing text* and edit as you like (See Figure 5).
4. Format text by using the buttons on the *Formatting Toolbar* (See Figure 5).

![Figure 5 - Editing Text](image-url)
Editing and Inserting Graphics
You can replace the graphics that Publisher has added to the home page with ones of your own choosing. You can also add your own graphics, or delete unwanted graphics.

Replacing an Image with an Image from the Internet
The following explains how to search for a replacement image on the internet:

1. Right-click on the image that you want to replace. An options menu will appear.
2. From the dialogue menu, click on Change Picture (See Figure 6).
3. Click on Change Picture (See Figure 6).

4. The Insert Pictures window will open. Next to Bing Image Search, type in a keyword for the picture you want to find in the Search box (See Figure 7).

Figure 6 - Change Picture

Figure 7 - Search for Pictures Online
5. Press **Enter** on your keyboard to run the search.
6. From the resulting choices, double-click on the **image** that you want. The new image now replaces the previous image.
7. To resize the picture, drag one of the **corners** toward or away from the center (See Figure 8).

![Figure 8 - Sizing Handles on Pictures](image)

### Replacing an Image with an Image File

The following explains how to replace an image with an image from your computer:

1. Right-click on the **image** that you want to replace.
2. From the **dialogue menu** that appears, click on **Change Picture** (See Figure 9).
3. Click on **Change Picture** (See Figure 9).

![Figure 9 - Change Picture](image)
4. The *Insert Pictures* window will open. Next to *From a file*, click on **Browse** (See Figure 10).

![Figure 10 – Insert Pictures from a File](image)

5. Browse to the location on your *computer* where your image is stored and double-click the *image*.
6. The new image will now replace the previous image.
7. To resize the picture, drag one of the **corners** toward or away from the center (See Figure 11).

![Figure 11 - Sizing Handles on Pictures](image)

**Inserting a Table**

Tables are frequently used in web pages for the purpose of layout and alignment. A table gives you a group of cells into which you can type text and insert images. Once you have inserted your table, you can access the formatting options to further modify the table.

1. From the *Insert* tab, click on **Table** (See Figure 12).

![Figure 12 - Click on Table](image)
2. A dropdown will appear. Select the **number of rows and columns** that you would like in your table. You can do this by dragging your mouse vertically and horizontally down the boxes, or you may do this from the **Insert Table** box (See Figure 13).

![Figure 13 - Inserting Tables]

3. Click on your **selection** to confirm. The table will appear in your **workspace** page (See Figure 14).

![Figure 14 - Table has been inserted into Page]

**Note:** The **Table Tools Contextual Tab** will appear on the menu bar when your table is selected and provides additional formatting options for your table (See Figure 15).

![Figure 15 - Table Tools Contextual Tabs]
4. Move and adjust your table by using the four point arrow which is visible when you mouse over the border of your table (See Figure 16).

![Figure 16 - Moving your Table](image)

5. You can now click in the cells of the table and either type **text** or insert **pictures** (See Figure 17).

![Figure 17 - Editing Contents of your Table](image)

**Inserting a Hyperlink**

The following explains how to insert a hyperlink:

1. Select the **text** that you want to use for the link.
2. From the **Insert** tab, click on **Hyperlink** (See Figure 18).

![Figure 18 - Insert Tab > Hyperlink](image)
3. The *Insert Hyperlink* window will appear. Type the address of the web site that you want to link to in the **Address** box (e.g., [http://www.kennesaw.edu](http://www.kennesaw.edu)) (See Figure 19).

![Figure 19 - Enter Address](image)

4. Click the **OK** button.

**Note:** The procedure above creates an “external” hyperlink---a link to another website. Publisher creates “internal” links (links to other pages on your website) automatically as you add new pages to your site (See Inserting Links within Your Site).

**Creating a Hotspot**

A hotspot is a picture or area of your website that hides a hyperlink. When visitors click on the hotspot, it will redirect them to the address specified in your hyperlink. The following explains how to create a hotspot:

1. Select the **Picture** that you want to use for the link (See Figure 20).

![Figure 20 - Select a Picture](image)
2. From the Insert tab, click on Hyperlink (See Figure 21).

![Hyperlink](Figure 21 - Insert Tab > Hyperlink)

3. The Edit Hyperlink window will appear. Type the address of the web site that you want to link to in the Address box (e.g. http://www.myoldwebsite.com) (See Figure 22).

![Address](Figure 22 - Enter Address)

4. Click the OK button. The picture will become a hotspot and will redirect to the hyperlink when clicked.
Inserting Links within Your Site

The following explains how to insert hyperlinks to pages within your website:

1. With your mouse, select the **text** that you want to link. The text “Create a Link to the Project List Page” has been selected as an example below (See Figure 23).

   ![Figure 23 - Select text to create the hyperlink](image1)

2. From the **Insert** tab, click on **Hyperlink** (See Figure 24).

   ![Figure 24 - Insert Tab > Hyperlink](image2)

3. The **Insert Hyperlink** window will open. Click on **Place in This Document** (See Figure 25).

   ![Figure 25 - Place in This Document](image3)
4. Under *Select a place in this document*, select one of the page destinations you would like to link. For example, “Page 4. Project List” has been selected (See Figure 26).

5. Click **OK** (See Figure 26).

![Figure 26 - Select Location and Click OK](image)

5. The text will now appear underlined as an active link. Simply select the text and you will be directed to the destination page (See Figure 27).

![Figure 27 - Active Link Created](image)
Inserting Additional Pages
The following explains how to add additional pages:

1. From the Insert tab, click on Page (See Figure 28).

![Figure 28 - Insert > Page]

2. A blank page will be inserted after your currently selected page.

Deleting Entire Pages
The following explains how to delete pages:

1. In the Page Navigation window, right-click on the page you would like to delete (See Figure 29).

![Figure 29 - Select a Page from the Navigation Window]
2. A *dialogue menu* will appear. Click on **Delete** to delete the page (See Figure 30).

![Figure 30 - Click on Delete](image)

**Note:** You can also delete the page by selecting the page and clicking on **Delete** from the *Page Design* tab (See Figure 31).

![Figure 31 - Page Design > Delete](image)

**Inserting Navigation Links**

The following explains how to add a navigation bar from an existing template:

1. Under the *Web* tab, click on the **Navigation Bar** button (See Figure 32).

![Figure 32 - Web > Navigation Bar](image)
2. The Building Block Library will open. Select the design you would like to add from the available options and click on Insert (See Figure 33).

![Building Block Library](image1)

Figure 33 - Building Block Library

3. The selected navigation bar design will is now added to your site. You can now move the navigation bar by dragging it to the desired location (See Figure 34).

![Navigation Bar Added](image2)

Figure 34 - Navigation Bar Added

**Running the Design Checker**

The Design Checker reviews your publication for a variety of design and layout problems, identifying these areas, and provides options to fix them. To run the Design Checker:

1. Click on the File tab (See Figure 35).

![Click on File Tab](image3)

Figure 35 - Click on File Tab
2. From the *Info* panel, click on **Run Design Checker** (See Figure 36).

![Figure 36 - Run Design Checker](image)

3. The *Design Checker* will open on the right-side of your screen and begin checking your publication for items to fix (See Figure 37).

![Figure 37 - Design Checker Results](image)
4. Click the **checkbox** next to **Run web site checks** (See Figure 38).

![Figure 38 - Run Web Site Checks](image)

5. The **Design Checker** will run web site checks. As items are discovered, they will appear under **Select an item to fix** with information on what the error is (See Figure 39).

![Figure 39 - Items to be fixed](image)

6. To fix an item, click on the **item from the list** and you will be redirected to the item. From here, you can make changes as needed.
Saving the Web Site
The following explains how to save your work:

1. From the File tab, click on **Save as** (See Figure 40).

   ![Figure 40 - File > Save as](image)

2. Select **Computer**, and click on **Browse** (See Figure 41).

   ![Figure 41 - Select Location to Save your File](image)
3. The *Save As* window will appear. Select a location on your computer where you want to save your web site files (See Figure 42).

![Figure 42 - Saving to the Desktop](image)

4. In the *File Name* field, name the file **index** (The home page of a website is always named “index”) (See Figure 43).

![Figure 43 - Name the File as index](image)
5. In the **Save as type** field, click the **dropdown arrow** and select **Web Page, Filtered** (See Figure 44).

![Figure 44 - Save file as Web Page, Filtered](image)

6. Click the **Save** button. Publisher will save the **index** file, and will also create a folder called **index files** which contains all the images and other pages on the website (See Figure 45).

![Figure 45 - Index Folder Created](image)

**Publishing the Web Site with SSH – Secure Shell FTP Client**

The Secure Shell FTP client is used to transfer files from one computer to another in a secure manner. This is especially useful when creating or updating your web pages. The main reason that it is needed is because creating and editing of web pages. This is usually not done on the web server but on a desktop or workstation computer. When a web page is created or edited on the local workstation, then the files need to be transferred to the web server.

**Note:** The Secure Shell FTP (SSFTP) client should be installed on all computers on campus.
To access the Secure File Transfer Client on-campus

- **Faculty/Staff**: Start by clicking on your *Start* button, then *All Programs*, then *SSH Secure Shell*, and click on *Secure File Transfer Client* (See Figure 46)
- **Student**: If you at a student lab computer, click on the *Start* button, then *Programs*, then *SSH Secure Shell*, and then *Secure File Transfer Client* (See Figure 46).

![Figure 46 - SSH Secure Shell > Secure File Transfer Client](image)

To Download the Secure File Transfer Client to a Personal Computer

1. Open a web browser and go to [http://uits.kennesaw.edu/downloads](http://uits.kennesaw.edu/downloads).
2. The *KSU Software Downloads* page will open. Enter your *NetID* and *credentials* and click *login*.
3. Click on *My Available Downloads* (See Figure 47).

![Figure 47 - My Available Downloads](image)
4. Scroll-down to Secure Shell File Transfer (SFTP) and click on View Files (See Figure 48).

```
<table>
<thead>
<tr>
<th>View Files</th>
<th>Secure Shell File Transfer (SFTP)</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Files</td>
<td>Client to securely transfer files to a server with encryption. Use Secure Shell SFTP to upload or download your files to campus web servers.</td>
</tr>
</tbody>
</table>
```

**Figure 48 - View Files**

5. The Software Download Agreement will appear. Click on Accept and Continue.

6. Next to the Installation File, click on Download File (See Figure 49).

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Download File</td>
<td>Instructions</td>
</tr>
<tr>
<td>Download File</td>
<td>Installation File</td>
</tr>
<tr>
<td></td>
<td>Windows setup file for SFTP.</td>
</tr>
</tbody>
</table>
```

**Figure 49 - Download File**

7. Save the installation file to your computer.

8. Once the installation file has finished downloading, double-click the install file to run the Secure File Transfer Client installer.

9. Follow the directions in the installer to install the Secure File Transfer Client on your computer.

**To Use the Secure File Transfer Client**
The following explains how to use the Secure File Transfer Client:

1. Start the Secure File Transfer Client program (See Figure 50).
2. Once the program opens, click the **Quick Connect** button on the main toolbar (See Figure 51).

![Figure 51 - Quick Connect](image)

**Note:** If you get a *File Open Error* message, ignore it and click **OK** (See Figure 52).

![Figure 52 - Ignore Error Message and Click OK](image)
3. The **Connect to Remote Host** window will open. Enter the following information:

**For students** (See Figure 53):
- **Hostname**: studentweb.kennesaw.edu
- **User Name**: enter your *NetID*
- **Port Number**: 22
- **Authentication Method**: Leave as <Profile Settings>

**For Faculty/Staff** (See Figure 53):
- **Hostname**: ksuweb.kennesaw.edu
- **User Name**: enter your *NetID*
- **Port Number**: 22
- **Authentication Method**: Leave as <Profile Settings>

**Note**: If you are a faculty/staff member using the ksuweb server, you should have been given a username and password when you applied for your account.

4. Click on **Connect**.
5. Click the **Yes** button on the **Host Identification** dialogue box if it appears (See Figure 54).

6. You will be asked for a password. Enter the password for your *NetID* (or if you are faculty/staff and are using the ksuweb server, enter the password for your *ksuweb username*), and click **OK**.
7. Once the connection is made, the program’s screen should be split in two:
   - The **left side (1)** shows the contents of the local computer (including disks and flash drives) (See Figure 55).
   - The **right side (2)** shows the contents of your space on the **studentweb** or the **ksuweb** server (See Figure 55).

![Figure 55 - Connection made to Server](image)

8. On the left (**local computer**) side of the screen, navigate to the location that contains your web files, or to the location to which you want to save your web files (See Figure 56).

![Figure 56 - Navigate to Local Files](image)
9. On the right (server content) side of the screen, double-click on the html folder to open it (only files in the html folder can be seen from the Internet) (See Figure 57).

![Figure 57 – Double-click on Html Folder](image)

**Note:** The following icons are useful when navigating your files (See Figure 58):

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Home Button" /></td>
<td><strong>On the local computer side,</strong> the home button takes you to the drive selection area in your “My Computer” window, where you can choose a disk, flash drive, or a folder on your hard drive.</td>
</tr>
<tr>
<td><img src="image" alt="Remote Button" /></td>
<td><strong>On the remote computer side,</strong> this button takes you to your home directory in your account on the server.</td>
</tr>
<tr>
<td><img src="image" alt="Up Button" /></td>
<td>The “UP” button takes you up one level on the directory structure.</td>
</tr>
</tbody>
</table>

![Figure 58 - Navigation Options](image)

10. You can drag and drop files from your local computer to the server and vice versa.

**Note:** Remember, your web pages must be in the html folder on the server to be accessible from the web. This is true for both the “studentweb” server and the “ksuweb” server.
Download Files from the Server

The following explains how to download a file from the server:

- Drag the file(s) from the right side (server) and drop it on the left side (local) (See Figure 59).

![Figure 59 - Download Files by Dragging](image)

- You can also right click on the file and then click download (See Figure 60).

![Figure 60 - Download](image)
**Upload Files to the Server**

The following explains how to upload a file to the server:

- Drag the **file** from the *left side (local)*, and drop it on the *right side (server)* (See Figure 61).

![Figure 61 - Upload Files by Dragging](image)

- You can also right click on the **file** and then click **upload** (See Figure 62).

![Figure 62 - Upload](image)

**Note:** Sending a file from your computer to the server is called uploading and getting a file from the server is called downloading.
Logging out of the Secure Shell FTP client
The following explains how to log out of the Secure Shell FTP client:

- To end the Secure File Transfer Client session, click the **Disconnect** button (See Figure 63).

![Figure 63 - Disconnect from Secure File Transfer Client](image)

Additional Help
For additional help or installation issues, please contact the KSU Service Desk:

**KSU Service Desk for Faculty & Staff**
Phone: 470-578-6999
Email: service@kennesaw.edu
Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)

**KSU Service Desk for Students**
Phone: 470-578-3555
Email: studenthelpdesk@kennesaw.edu
Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)