Creating Interactive PDF Forms

Using Adobe Acrobat X Pro
# Creating Interactive Forms with Adobe Acrobat X Pro

## Table of Contents

1. Introduction to Interactive PDF Forms ................................................................. 5

2. Creating an Interactive Form ............................................................................... 5
   2.1 Creating a Form from an Electronic Document ............................................. 5
   2.2 Creating a Form from a Scanned Document .................................................. 7
   2.3 Creating a Form from Scratch ....................................................................... 9

3. Adding Form Elements to a Form ....................................................................... 9
   3.1 Adding a Text Field ..................................................................................... 11
   3.2 Setting Text Field Properties ....................................................................... 12
   3.3 Adding a Check Box ................................................................................... 13
   3.4 Setting Check Box Properties ....................................................................... 14
   3.5 Adding a Radio Button (Group) .................................................................... 14
   3.6 Setting Radio Button Properties ................................................................... 15
   3.7 Adding a List Box ...................................................................................... 16
   3.8 Setting List Box Properties .......................................................................... 18
   3.9 Adding a Dropdown ..................................................................................... 18
   3.10 Setting Dropdown Properties ....................................................................... 20

4. Adding a Button .................................................................................................. 21
   4.1 Adding a “Clear Form” Button ................................................................... 21
   4.2 Adding a “Submit Form” Button ................................................................... 22

5. Form Layout ....................................................................................................... 24
   5.1 Resizing Form Fields .................................................................................. 24
   5.2 Moving Form Fields .................................................................................... 25
   5.3 Aligning Form Fields .................................................................................. 25
   5.4 Adjusting Spacing Between Fields ............................................................... 26
   5.5 Deleting a Field .......................................................................................... 26

6. Setting Tab Order .............................................................................................. 26
1. Introduction to Interactive PDF Forms

Electronic forms have clear advantages over standard paper forms. Not only can they be made available to users online or distributed via email, but they can include interactive functionality that makes them easier and more reliable to use.

Using Adobe Acrobat Pro, you can create interactive forms that users can fill in and submit as a complete form, or, you can just collect the data that the users fill in. Acrobat Pro also allows you to build in added functionality, such as data validation, automatic calculation of numbers, and exporting of values to a database.

Included with Acrobat Pro is another program called LiveCycle Designer which is used exclusively for forms design, and offers a collection of features and controls not available in Acrobat Pro. However, a form created in LiveCycle, or a form created in Acrobat Pro and then edited in LiveCycle, can no longer be edited in Acrobat Pro. Using LiveCycle Designer is beyond the scope of this document.

2. Creating an Interactive Form

There are three ways to begin creating a form in Acrobat Pro: from an electronic document, from a scanned document, and from scratch (blank). Regardless of the method you use to begin, you will need to do some editing to the form and add form elements. Adding form elements to the form is covered in section 3 of this document.

2.1 Creating a Form from an Electronic Document

Using Acrobat Pro, you can create a PDF form from a Word document. Acrobat Pro will automatically recognize possible form fields, and identify these fields in the PDF form. Some fields in the new form—such as text fields—will work just as they are; others will need to be added or modified.

Many people are familiar with creating interactive forms in Microsoft Word. Word has the ability to save any document in PDF format. However, when a Word document containing form fields is saved as a PDF, the interactive functionality of the Word form fields does not carry over into the PDF. In this instance, Word is creating a basic PDF, not an interactive PDF form.

The example below explains how to create an interactive PDF form from a Word document.

Figure 1 - Menu Bar & Toolbars

1. On the Acrobat Pro toolbar, click Create.
2. On the **Create** menu, click **PDF Form or Online Form**.

3. In the **Create or Edit Form** dialog box, select **Use the current document or browse to a file**.
4. Click the **Next** button.

5. Click the **Browse** button and select the document that you want to use.
6. Click the **Next** button. Acrobat Pro begins converting the document.
7. A message window appears indicating that Acrobat has automatically detected form fields.
8. Click the OK button to close the window.

You should now see your document in Acrobat Pro.

Figure 5 - PDF Form Created from Word Form

The screen shot in Figure 5 shows a portion of a Word form that was converted to PDF in Acrobat Pro. In this case, the Word document was simply a table that had been used as a paper form. However, due to the structure, Acrobat Pro was able to detect many of the form fields.

2.2 Creating a Form from a Scanned Document

When you create a form from a scanned document, you are essentially creating a form from a picture of the document. This method will allow you to quickly create an interactive PDF form from an existing paper form; however, you cannot edit any text or formatting from your original paper form.

The steps below explain how to create an interactive PDF form from a scanned document.

Figure 6 - Menu Bar & Toolbars

1. On the Acrobat Pro toolbar, click Create.
2. On the **Create** menu, click **PDF Form**.

![Create or Edit Form dialog box](image)

Figure 8 – Choosing the Source

3. In the **Create or Edit Form** dialog box, select **Use an existing file** if you have already scanned in your paper form.

   **Note:** If you have a scanner attached to your computer, Acrobat X Pro also has an option for bringing in an image directly from the scanner. Choose **Scan a paper form** if you need to scan your paper form at this time, then skip to step 7.

4. Click the **Next** button.

![Create or Edit Form dialog box](image)

Figure 9 - Locating the Document

5. Click the **Browse** button and select the scanned file on your computer.
6. Click the **Next** button. Acrobat Pro begins converting the document.
7. A message window appears indicating that Acrobat has automatically detected form fields.
8. Click the **OK** button to close the window.

You should now see the scanned form in Acrobat Pro.
2.3 Creating a Form from Scratch

To create a form from scratch, begin by creating a blank page:

![Tools menu](image)

Figure 10 - Tools menu

1. On the right side of the Acrobat Toolbar, click **Tools**. The **Tools Pane** opens.

![Pages in the Tools Pane](image)

Figure 11 - Pages in the Tools Pane

2. In the **Panels** area on the right side of the screen, click **Pages**. The **Pages Panel** opens.

![More insert options](image)

Figure 12 - More insert options

3. Click **More Insert Options**.

![Insert blank page](image)

Figure 13 - Insert blank page

4. Click **Insert Blank Page**.

Now you can add form elements to the page, as described in the next sections.

3. Adding Form Elements to a Form

A form element is an object that allows the user to input data. The basic form element is the text field, which is used to enter text. However, Acrobat Pro includes six useful types of form elements. The following is a list of form elements:

- **Text Field** – lets the user type text
- **Check Box** – gives the user a yes-or-no choice for a single item or list of items
- **Radio Button** – presents a group of choices from which the user can select only one item
- **List Box** – displays a list of options from which the user can select
- **Dropdown** – lets the user either choose an item from a list or type in a value
- **Button** – initiates a change or an action on the user’s computer

To add form elements, you must first open the form in edit mode:

![Partial Acrobat Toolbar](image)

**Figure 14 - Partial Acrobat Toolbar**

1. On the right side of the Acrobat Toolbar, click **Tools**. The **Tools Pane** opens.

![Forms in Tools Panel](image)

**Figure 15 – Forms in Tools Panel**

2. In the **Panels** area on the right side of the screen, click **Forms**. The **Forms Panel** opens.

![Forms Panel](image)

**Figure 16 - Forms Panel**

3. In the **Forms Panel**, click **Edit**. The form opens in edit mode, and the **Tasks Panel**, **Fields Panel** and **Form Tools** are displayed:
The process of adding form elements is the same, regardless of which form element you are adding. There are differences, however, in the properties of each element. **Note: the functionality of a form element is determined by the type and the properties you select.**

### 3.1 Adding a Text Field

1. In the **Tasks Panel**, click **Add New Field**.
2. Select **Text Field** from the drop-down list. A shaded box representing the Text Field appears.
3. Position the shaded box in the proper location on the form, and then click the mouse button.
4. Type a descriptive name for the field in the **Field Name** box.
5. Click the **Required field** check box, if appropriate.
6. Click the **All Properties** link.
7. Set properties as needed. (See section 3.2. for Text Field properties).
8. Click outside the field area.

### 3.2 Setting Text Field Properties

You can access the Text Field properties at the time you create the Text Field by clicking the **All Properties** link on the **Field Name** dialog box, or later by double-clicking on the Text Field.

- **General**
  - **Name**: a reference name for the field. This name is for your use; not visible to form recipient
  - **Tooltip**: a description of the field shown when a user hovers the mouse pointer over the field
  - **Form Field: (visibility)** – determines whether the field will be visible on screen/when printed
  - **Orientation**: tilts the field 90, 180, or 270 degrees
  - **Read Only**: prevents changes to the field
  - **Required**: requires the user to fill in the field

- **Appearance**
  - **Border Color**: sets the color of the field border
  - **Fill Color**: sets the color inside the field border
  - **Line Thickness**: sets the thickness of the border
  - **Line Style**: sets the border line as solid, dotted, or dashed
  - **Font Size**: sets the size of the font
  - **Text Color**: sets the color of the text
  - **Font**: sets the font used

- **Options**
  - **Alignment**: aligns the text left, center, or right
  - **Default Value**: the text that appears in the field before the user enters text
  - **Multi-line**: allows the user press the enter key and type multiple lines of text
  - **Scroll long text**: causes a scroll bar to appear when a text box is over-filled with text
    - **Note**: the overflow text will not show if the filled form is printed
  - **Allow Rich Text Formatting**: allows text formatting such as bold, italics, etc.
  - **Limit of ___ characters**: limits the field to a specific number of characters
  - **Password**: displays user-entered text as a series of asterisks. *Not available if spell check is turned on.*
  - **Check spelling**: checks the spelling of text in the field

- **Actions**: Cause an event to take place automatically as a result of the user interacting with the Text Box.
  - **Select Trigger**: sets the screen activity that causes the action to occur
  - **Select Action**: sets the type of action that occurs as a result of the trigger
  - **Actions**: the specific actions (a sub-set of “Select Action”) that occur as a result of the trigger. *Multiple actions can be added and arranged.*
• **Format**: Defines the type of data that will be entered in the field (date, number, etc.)

Most of the format categories are self-explanatory; however, when you select a category from the drop-down, a short description of the category is displayed in the lower part of the Properties window.

• **Validate**: Validation properties restrict entries to specified ranges, values, or characters, ensuring that users enter the appropriate data.
  - Field is not validated: turns validation on or off
  - Field value is in range: sets a numeric range using values you enter either as a number or a percentage
  - Run custom validation script: validates by a JavaScript that you provide

• **Calculate**: These options perform mathematical operations on existing form field entries and display the result.
  - Value is not calculated: indicates that the user will enter the data for the field
  - Value is in the: selecting this makes further options available
    - Pop-up menu: lists the mathematical functions to apply to the selected fields
    - Pick: opens a dialog box with a list of the available fields in the form that you select to add or deselect to remove from the calculation
  - Simplified field notation: uses JavaScript with field names and simple arithmetic signs to perform the calculation
  - Custom calculation script: displays any custom scripts you have added for calculations

### 3.3 Adding a Check Box

Check Boxes should be used to create lists of items where zero, one, or more items can be selected. (To make a list of items where only one item can be selected, use the Radio Button form element.)

1. In the **Tasks Panel**, click **Add New Field**.
2. Select **Check Box** from the drop-down list. A shaded box representing the Check Box appears.
3. Position the shaded box in the proper location on the form, and then click the mouse button.

![Figure 21 - Check Box Form Element](image)

4. Type a descriptive name for the field in the **Field Name** box.
5. Click the **Required field** check box, if appropriate.
6. Click the **All Properties** link.
7. Set properties as needed. (See section 3.4 for Check Box properties).
8. Click outside the field area.
9. Repeat steps 1–8 until all checkboxes have been added.
3.4 Setting Check Box Properties

You can access the Check Box properties at the time you create the Check Box by clicking the All Properties link on the Field Name dialog box, or later by double-clicking on the Check Box.

- **General Tab**
  - Name: a reference name for the field. This name is for your use; not visible to form recipient
  - Tooltip: a description of the field shown when a user hovers the mouse pointer over the field
  - Form Field (visibility): determines whether the field will be visible on screen or when printed
  - Orientation: tilts the field 90, 180, or 270 degrees
  - Read Only: prevents changes to the field
  - Required: requires the user to fill in the field

- **Appearance**
  - Border Color: sets the color of the field border
  - Fill Color: sets the color inside the field border
  - Line Thickness: sets the thickness of the border
  - Line Style: sets the border line as solid, dotted, or dashed
  - Font Size: sets the size of the font
  - Text Color: sets the color of the text
  - Font: sets the font used

- **Options**
  - Check Box Style: sets the shape of the Check Box
  - Export Value: specifies a value to represent the item if the data will be exported. If left blank, the entry for Name in the General tab is used as the export value.
  - Check box is checked by default: shows the Check Box selected unless the user deselects it.

- **Actions**: Cause an event to take place automatically as a result of the user interacting with the Check Box.
  - Select Trigger: sets the screen activity that causes the action to occur
  - Select Action: sets the type of action that occurs as a result of the trigger
  - Actions: the specific actions (a sub-set of “Select Action”) that occur as a result of the trigger. *Multiple actions can be added and arranged.*

3.5 Adding a Radio Button (Group)

Radio Buttons (in groups) should be used to make a list of items where only one item in the group can be selected. The following example illustrates the use of radio buttons:

My age is:

- Under 18 years
- 19–25 years
- 26–40 years
- 40–65 years
- 66 years or older

1. In the Tasks Panel, click Add New Field.
2. Select Radio Button from the drop-down list. A shaded box representing the Radio Button appears.
3. Position the shaded box in the proper location on the form, and then click the mouse button.

4. Type a descriptive name for the field in the **Field Name** box.

5. Type a descriptive Group Name. **All buttons with the same Group Name will be part of the same group.**

6. Click **Add Another Button**.

7. Use the blue alignment lines and the rulers to roughly align the shaded box with the previous one. You can align the radio buttons more precisely once you get them all created.

8. Repeat steps 6 and 7 until you have added all the radio buttons that you need.

9. Click the **Required field** check box, if appropriate.

10. Click the **All Properties** link.

11. Set properties as needed. The properties that you set will apply to all radio buttons in the group. (See section 3.6 for Radio Button properties).

12. Click the **Close** button.

You will probably need to resize and align the radio buttons in the group. See section 5.1 for instructions on resizing form fields. See section 5.3 for instructions on aligning form fields.

### 3.6 Setting Radio Button Properties

You can access the Radio Button properties at the time you create the Radio Button by clicking the **All Properties** link on the **Field Name** dialog box, or later by double-clicking on the Radio Button.

- **General**
  - **Name** – a reference name for the field
  - **Tooltip** – a description of the field that appears when a user holds the mouse pointer over the field
  - **Form Field: (visibility)** – determines whether or not the field will be visible on screen and/or when printed
  - **Orientation**: tilts the field 90, 180, or 270 degrees
  - **Read Only**: prevents changes to the field
• **Required**: requires the user to fill in the field; setting a radio button to required will require the user to select one item from the *group* of radio buttons.

• **Appearance**
  - **Border Color**: sets the color of the field border
  - **Fill Color**: sets the color inside the field border
  - **Line Thickness**: sets the thickness of the border
  - **Line Style**: sets the border line as solid, dotted, or dashed
  - **Font Size**: sets the size of the font
  - **Text Color**: sets the color of the text
  - **Font**: sets the font used

• **Options**
  - **Check Box Style**: sets the shape of the Check Box
  - **Export Value**: specifies a value to represent the item if the data will be exported. If left blank, the entry for Name in the General tab is used as the export value.
  - **Check box is checked by default**: shows the Check Box selected unless the user deselects it.

• **Actions**: Cause an event to take place automatically as a result of the user interacting with the Radio Button.
  - **Select Trigger**: sets the screen activity that causes the action to occur
  - **Select Action**: sets the type of action that occurs as a result of the trigger
  - **Actions**: the specific actions (a sub-set of “Select Action”) that occur as a result of the trigger. *Multiple actions can be added and arranged.*

### 3.7 Adding a List Box

A list box shows all available options in list form. Users can select one or multiple list items.

You may find that a List Box that contains many items occupies too much space on your form. In this case, you might want to use a Dropdown instead. See section 3.9 for Dropdown instructions.

1. In the **Tasks Panel**, click **Add New Field**.
2. Select **List Box** from the drop-down list. A rectangle representing the List Box appears.
3. Position the rectangle in the proper location on the form, and then click the mouse button.

![Figure 23 - List Box Form Element](image)

4. Type a descriptive name for the field **Field Name** area.
5. Click the **Required field** check box, if appropriate.
6. Click the **All Properties** link.

List Items (the items that are displayed in the List Box) are created on the **Options** tab of the **List Box Properties**. Since the List Items are essential to the functioning of List Box, the Options tab is covered here. See section 3.8 for other List Box properties.

7. **Click the Options tab.**

8. Type an item into the **Item** field, and then click the **Add** button. The item now appears in the **Item List**.
9. If the data on the form is going to be collected in a database, and you want the value exported to the database to be different than the item selected in the list, type the value in the Export Value box.
10. Repeat steps 9 and 10 until you have added all the items to the list.
11. To change the position of an item in the list, select the item, and then click the **Up** or **Down** button.
    (Alternatively, you can sort the list.)
12. To sort the list, click the **Sort items** check box. Items will be sorted alphabetically.
13. To allow the user to select more than one item in the list, click the **Multiple selection** check box.
14. To save the value as soon as the user selects it, click the **Commit selected value immediately**. If this option is not selected, the value is saved only when the user tabs out of the current field or clicks another form field. This option is not available if Multiple Selection is selected.
15. If you want to make an item in the list the default choice, select that item. Otherwise, make sure no items in the list are selected.

### 3.8 Setting List Box Properties

You can access the List Box properties at the time you create the List Box by clicking the **All Properties** link on the **Field Name** dialog box, or later by double-clicking on the List Box.

- **General**
  - **Name** – a reference name for the field
  - **Tooltip** – a description of the field that appears when a user holds the mouse pointer over the field
  - **Form Field: (visibility)** – determines whether or not the field will be visible on screen and/or when printed
  - **Orientation**: tilts the field 90, 180, or 270 degrees
  - **Read Only**: prevents changes to the field
  - **Required**: requires the user to fill-in the field

- **Appearance**
  - **Border Color**: sets the color of the field border
  - **Fill Color**: sets the color inside the field border
  - **Line Thickness**: sets the thickness of the border
  - **Line Style**: sets the border line as solid, dotted, or dashed
  - **Font Size**: sets the size of the font
  - **Text Color**: sets the color of the text
  - **Font**: sets the font used

- **Options** Options properties are covered in section 3.7.

- **Actions**: Cause an event to occur automatically as a result of the user interacting with the List Box.
  - **Select Trigger**: sets the screen activity that causes the action to occur
  - **Select Action**: sets the type of action that occurs as a result of the trigger
  - **Actions**: the specific actions (a sub-set of “Select Action”) that occur as a result of the trigger.
    *Multiple actions can be added and arranged.*

- **Selection Change**
  - **Do nothing**: no code is executed when an item is selected from the list.
  - **Execute this script**: allows JavaScript code to be executed when an item is selected from the list. For example, an information box might open when a particular item is selected.

### 3.9 Adding a Dropdown

The Dropdown, like the List Box, can contain an unlimited number of items from which the user can select. Unlike the List Box, however, these items only appear when the user clicks the Dropdown. Also, the user has the option of typing an item that does not appear in the Dropdown into the field.
1. In the **Tasks Panel**, click **Add New Field**.
2. Select **Dropdown** from the drop-down list. A rectangle representing the Dropdown appears.
3. Position the rectangle in the proper location on the form, and then click the mouse button.

![Dropdown Form Element](image)

**Figure 26 - Dropdown Form Element**

4. Type a descriptive name for the field **Field Name** area.
5. Click the **Required field** check box, if appropriate.
6. Click the **All Properties** link.

List items (the items that are displayed when the user clicks the Dropdown) are created on the **Options** tab of the **Dropdown Properties**. Since the list items are essential to the functioning of Dropdown, the Options tab is covered here. See section 3.10 for other Dropdown properties.

7. Click the **Options** tab.

![Dropdown Options Properties](image)

**Figure 27 - Dropdown Options Properties**

8. Type an item into the **Item** field, and then click the **Add** button. The item now appears in the **Item List**.
9. If the data on the form is going to be collected in a database, and you want the value exported to the database to be different than the item selected in the list, type the value in the Export Value box.
10. Repeat steps 9 and 10 until you have added all the items to the list.
11. To change the position of an item in the list, select the item, and then click the **Up** or **Down** button.
(Alternatively, you can sort the list.)
12. To sort the list, click the **Sort items** check box.
13. To allow the user to type text into the field, rather than select an item from the list, click the **Allow user to enter custom text** check box.
14. To turn on spell checking, click the **Check spelling** check box.
15. To save the value as soon as the user selects it, click the **Commit selected value immediately**. If this option is not selected, the value is saved only when the user tabs out of the current field or clicks another form field.
16. If you want to make an item in the list the default choice, select that item.

### 3.10 Setting Dropdown Properties

You can access the Dropdown properties at the time you create the Dropdown by clicking the **All Properties** link on the **Field Name** dialog box, or later by double-clicking on the Dropdown.

- **General**
  - **Name** – a reference name for the field
  - **Tooltip** – a description of the field that appears when a user holds the mouse pointer over the field
  - **Form Field: (visibility)** – determines whether or not the field will be visible on screen and/or when printed
  - **Orientation**: tilts the field 90, 180, or 270 degrees
  - **Read Only**: prevents changes to the field
  - **Required**: requires the user to fill-in the field

- **Appearance**
  - **Border Color**: sets the color of the field border
  - **Fill Color**: sets the color inside the field border
  - **Line Thickness**: sets the thickness of the border
  - **Line Style**: sets the border line as solid, dotted, or dashed
  - **Font Size**: sets the size of the font
  - **Text Color**: sets the color of the text
Creating Interactive Forms with Adobe Acrobat Pro X  Page 21 of 46

- **Font**: sets the font used

**Options**
Options properties are covered in section 3.9.

- **Actions**: Cause an event to take place automatically as a result of the user interacting with the Dropdown.
  - **Select Trigger**: sets the screen activity that causes the action to occur
  - **Select Action**: sets the type of action that occurs as a result of the trigger
  - **Actions**: the specific actions (a sub-set of “Select Action”) that occur as a result of the trigger. *Multiple actions can be added and arranged.*

- **Format**: Defines the type of data that will be entered in the field (date, number, etc.)

- **Validate**: Validation properties restrict entries to specified ranges, values, or characters, ensuring the user enters the appropriate data for the field.
  - **Field value is not validated**: turns off validation
  - **Field Value is in range**: sets a numeric range of values that can be entered into the field
  - **Run custom validation script**: validates by a JavaScript that you create or provide

- **Calculate**: These options perform mathematical operations on existing form field entries and display the result.
  - **Value is not calculated**: indicates that the user will enter the data for the field
  - **Value is in the**: selecting this makes further options available
    - **Pop-up menu**: lists the mathematical functions to apply to the selected fields
    - **Pick**: opens a dialog box with a list of the available fields in the form that you select to add or deselect to remove from the calculation
  - **Simplified field notation**: uses JavaScript with field names and simple arithmetic signs to perform the calculation
  - **Custom calculation script**: displays any custom scripts you have added for calculations

4. **Adding a Button**

A button is used to perform an action, such as clearing the form fields.

4.1 **Adding a “Clear Form” Button**

1. Click **Tools → Forms → Edit → Add New Field**.
2. Select **Button** from the drop-down list. A shaded box representing the button appears.
3. Position the shaded box in the proper location on the form, and then click the mouse button.

![Figure 29 - Inserting a button](image-url)
4. Type “Clear” in the Field Name box.
5. Click the All Properties link. The Button Properties dialog box opens.
6. On the General tab, click the Form Field dropdown and select “Visible but doesn’t print” to prevent the button from appearing on the form when it is printed.
7. On the General tab, click the Read Only checkbox to prevent the cursor from stopping on the button when the user presses the Tab key.
8. Click the Appearance tab and set the options as you prefer.
9. Click the Options tab and type “Clear Form” in the Label box.

**NOTE:** The Label is the only text that will appear on the button for the form recipient.

10. Click the Actions tab.

![Button Properties dialog box](image)

**Figure 30 - Reset a Form action**

11. Click the Select Action box.
12. Select Reset a form from the list of actions.
13. Click the Add button. The Reset a Form dialog box opens.
14. In the Select Fields to Reset area, un-check any fields that you do not want cleared.
15. Click the OK button.
16. Click the Close button on the Button Properties dialog box.

To test the Clear Form button:
1. Click Preview on the toolbar.
2. Click the Clear Form button.

### 4.2 Adding a “Submit Form” Button

1. Click Tools → Forms → Edit → Add New Field.
2. Select **Button** from the drop-down list. A shaded box representing the button appears.
3. Position the shaded box in the proper location on the form, and then click the mouse button.
4. Type “Submit” in the **Field Name** box.
5. Click the **All Properties** link. The **Button Properties** dialog box opens.
6. Click the **Appearance** tab and set the options as you prefer.
7. Click the **Options** tab and type “Submit” in the **Label** box.

**NOTE:** The Label is the only text that will appear on the button for the form recipient.

8. Click the **Actions** tab.
9. Click the **Select Action** dropdown.
10. Scroll to the bottom of the drop-down list and select **Submit a form**.
11. Click the **Add** button. The **Submit Form Selections** dialog box opens.
12. In the box labeled **Enter a URL for this link**, type “mailto:” followed by the email address where you want the completed form sent (e.g., mailto:xyz@kennesaw.edu).
13. In the **Export Format** area, click the radio button labeled **PDF**.
14. Click the **OK** button.
15. Click the **Close** button on the **Button Properties** dialog box.

To test the **Submit** button:
1. Click **Preview** on the toolbar.
2. Click the **Submit** button. The **Select Email Client** dialog box opens.

*Remember, this is what the user of the form will see:*

![Select Email Client Dialog Box](image)

3. Select one of the options on the **Select Email Client** dialog box.
   - **Desktop Email Application**: When a user selects **Desktop Email Application**, Acrobat opens a new message in the user’s desktop email client with the form attached.
• **Internet Email**: Acrobat is not able to hand the form off to an Internet Email service, such as Gmail or Zimbra. A recipient who does not have a desktop email client (such as most students) will be prompted to save the form, then email it.

4. Click **OK**.

5. **Form Layout**

   After you create form fields, you can rearrange, resize, or move them to give the page a cleaner, more professional look.

5.1 **Resizing Form Fields**

1. On the right side of the **Toolbar**, click **Tools**.
2. In the **Panels** area on the right side of the screen, click **Forms**.
3. In the **Forms Panel**, click **Edit**.
4. Do any of the following:
   - To resize the field manually, click and drag a corner border handle. Press and hold the Shift key to maintain the current height/width ratio of the field.
   - To resize the field by one pixel, press Ctrl+Arrow key; to resize the field by ten pixels, press Ctrl+Shift+Arrow key

   **To resize multiple form fields to match a selected form field:**

   1. Select all the form fields that you want to resize.
   2. Right-click the form field that you want the other selected form fields to match.

3. Click **Set Fields To Same Size**, and then select one of the following:
   - **Height**: adjusts the heights to match the height of the reference field, without changing the widths.
• **Width**: adjusts the widths to match the width of the reference field, without changing the heights.
• **Both**: adjusts both the heights and widths to match the reference field.

### 5.2 Moving Form Fields

1. On the right side of the **Toolbar**, click **Tools**.
2. In the **Panels** area on the right side of the screen, click **Forms**.
3. In the **Forms Panel**, click **Edit**.
4. Select the field(s) that you want to move.
5. Do one of the following:
   • To move to an approximate location, drag the selected fields to the new location. To constrain movement to a horizontal or vertical direction, begin dragging, and then press Shift while continuing to drag the selection.
   • To move either horizontally or vertically in small increments, press the arrow keys to nudge the selected form fields into position.

### 5.3 Aligning Form Fields

1. On the right side of the **Toolbar**, click **Tools**.
2. In the **Panels** area on the right side of the screen, click **Forms**.
3. In the **Forms Panel**, click **Edit**.
4. Select two or more fields that you want to align.
5. Right-click the field to which you want to align the other fields.
6. Choose **Align, Distribute Or Center**, and then choose a command as follows:
   • To align a row of fields, choose **Align Top, Bottom, or Horizontally**. They align respectively to the top edge, bottom edge, or horizontal axis (center) of the anchor form field.
   • To center the fields, choose **Center Vertically, Horizontally, or Both**.

![Figure 33 – Align, Distribute or Center Menu](image)

**Note**: When you right-click one of the selected fields, it shows the border handles, indicating that it’s the anchor form field. The “Align” menu commands move the other selected form fields to line up with the edges of the anchor form field.
5.4 Adjusting Spacing Between Fields

In the context of laying out form fields on a page, “distributing” means to give a group of form fields uniform spacing, measured from the centers of adjacent fields.

1. On the right side of the Toolbar, click Tools.
2. In the Panels area on the right side of the screen, click Forms.
3. In the Forms Panel, click Edit.
4. Select two or more fields that you want to adjust.
5. Right-click any one of the selected fields and do one of the following:

   - To distribute the fields evenly between the topmost and bottommost fields, choose Align, Distribute or Center → Distribute Vertically.
   - To distribute the fields evenly between the leftmost and rightmost fields, choose Align, Distribute or Center → Distribute Horizontally.

![Figure 34 – Align, Distribute or Center Menu](image)

**Note:** The Distribute Form button in the Forms toolbar has a different function: Use that button to send your form to others, who fill in the information and return the data to you.

5.5 Deleting a Field

1. On the right side of the Toolbar, click Tools.
2. In the Panels area on the right side of the screen, click Forms.
3. In the Forms Panel, click Edit.
4. Select the fields that you want to delete.
5. Press the Delete key, or click Edit → Delete on the menu bar.

6. Setting Tab Order

The order in which the user fills in the fields of a form should be logical. Forms are usually filled in from top to bottom, or left to right. The user can move from field to field by clicking the fields, but it is much quicker and easier to use the Tab key.
Depending on how you create the form and lay out the form fields, the “tab order”—the order in which the cursor moves from field to field when the user presses the tab key—may be correct, or it may not. If the tab order is not correct, you can set it.

![Fields Panel]

Figure 35 - Fields Panel

When a form is open in edit mode, the **Fields Panel** is visible at the right side of the screen. This panel displays the name of each field on the form.

![Tab Order Menu]

Figure 36 - Tab Order Menu

Form fields in the Fields Panel are, by default, sorted by tab order.

The **Tab Order** drop-down menu is visible at the top of the **Fields Panel**.

To set the tab order of the fields:

1. Click **Tab Order**.
2. On the **Tab Order** drop-down menu, select **Show Tab Numbers**.
3. Click **OK** on the pop-up message. On the form, you now see a number at the top left corner of each field representing the order in which the cursor will move to the fields when the tab key is pressed.

Check the numbering throughout the form. If you are satisfied with the tab order, stop here. If you want to change the tab order, continue with the next step.

4. Click **Tab Order** again.
5. On the **Tab Order** drop-down menu, select either **Order Tabs by Structure**, **by Row**, or **by Column** to have Acrobat Pro automatically order the tabs.
Check the numbering throughout the form. If you are satisfied with the tab order, stop here. If you want to change the tab order manually, continue with the next step.

6. Select **Order Tabs Manually**.

   ![Adobe Acrobat Tab Order Information Message](image)

   **Figure 37 - Tab Order Information Message**

7. Read the information in the pop-up message, and then click the **OK** button.
8. In the **Fields Panel**, drag and drop the fields where you want them. You will see the numbers in the fields change on the form.
9. When you are satisfied with the tab order, click the **Close Form Editing** in the **Tasks Panel**.
10. Tab through the form and verify that the tab order is correct.

   **Note:** Tab order should be the last item you set on your form. If you make any changes to the form, you will have to set your manual tab order again.

7. **Updating a Form**

   If you created your form from a Word document, you may make updates to your original document in Word. Perform the following steps to import your updated Word document into the form you have already created in Acrobat Pro.

   1. Open your existing PDF form in Acrobat Pro.
   2. From the **Pages** menu, choose **Replace**.
3. You will be prompted to browse to your updated Word document on your computer. Make sure to change the **Files of type** dropdown to **All Files (.*.*)**. Then, browse to your file and select it.

4. A progress bar will appear in the lower-right corner of your PDF while Acrobat processes the page.

5. You will be prompted to select the pages to be replaced. The top selection determines which pages of your PDF you are replacing; the bottom selection determines which pages you are using from your updated Word document. Enter the appropriate page numbers.
6. Click OK.
7. When you receive the prompt, “Are you sure you want to replace page X?”, click Yes.
8. The pages have been replaced. All existing form fields are maintained.
9. Enter Form Editing mode by clicking Forms ➔ Edit.
10. You can now adjust your existing form fields or add new form fields as needed.

8. Securing a Form with a Password
You can use password protection to prevent unauthorized people from opening, editing, or printing the form.

Note: Password protection does not encrypt the data on the returned form. See section 10.5, Using the Distribute Form Wizard for information on securing form data.

8.1 Setting Password Security
1. Click Tools at the right side of the Toolbar.
2. Click Protection in the Tools Pane.
3. Click Encrypt in the Protection Panel.
4. Click Encrypt with Password.

5. If the Applying New Security Settings dialog box appears, click the Yes button. The Password Security Settings dialog box appears.

6. If you want to allow users with older versions of Acrobat to be able to use the form, or, if you want to limit the use of the form to only users who have the current version, you can click the Compatibility drop-down box and select a different version than the default.

7. Select an option in the Select Document Components to Encrypt section.
   - Encrypt all document contents prevents any changes to the document.
   - Encrypt all document contents except metadata: Select this option to encrypt the contents of a document but still allow search engines access to the document metadata. This option is available when you select compatibility to Acrobat 6.0 and later.
• **Encrypt only file attachments**: Select this option to require a password for opening file attachments. However, users can open the PDF without a password. Use this setting for security envelopes. This option is available when you set compatibility for Acrobat 7.0 and later.

8. Select other options that you wish to enable.

• **Require a password to open the document**: Select this option to require users to type the password you specify to open the document. This option is unavailable if Encrypt Only File Attachments is selected.
  
  o **Document Open Password**: Specify the password that users must type to open the PDF file. **Warning**: If you forget a password, there is no way to recover it from the document. It’s a good idea to store passwords in a separate secure location in case you forget them.

• **Restrict editing and printing of the document**: Restricts access to the PDF file’s security settings. If the file is opened in Acrobat, the user can view the file but must enter the specified Permissions password to change the security and permissions settings.
  
  o **Change Permissions Password**: Specify a password that is required to change the permissions settings. This option is available only if the previous option is selected.

• **Printing Allowed**: Specifies the level of printing that users are allowed for the PDF document.
  
  o **"None”** prevents users from printing the document.
  
  o **“Low Resolution (150 dpi)”** lets users print at no higher than 150-dpi resolution. Printing can be slower because each page is printed as a bitmap image. This option is available only if the Compatibility option is set to Acrobat 5.0 or Later.
  
  o **“High Resolution”** lets users print at any resolution, directing high-quality vector output to PostScript® and other printers that support advanced high-quality printing features.

• **Changes Allowed**: Defines which editing actions are allowed in the PDF document.
  
  o **“None”** prevents users from making the changes that are listed in the Changes Allowed menu, such as filling in form fields and adding comments.
  
  o **“Inserting, deleting, and rotating pages”** lets users perform those functions, as well as create bookmarks and thumbnails.
  
  o **“Filling in form fields and signing existing signature fields”** lets users fill in forms and add digital signatures.
  
  o **“Commenting, filling in form fields, and signing existing signature fields”** lets users add comments and digital signatures, and fill in forms. This option does not allow user to move page objects or create form fields.
  
  o **“Any except extracting pages”** lets users make any changes other than extracting pages from the document.

• **Enable Copying of Text, Images, and Other Content**: Lets users select and copy the contents of a PDF.

• **Enable Text Access for Screen Reader Devices for The Visually Impaired**: Lets visually impaired users read the document with screen readers, but doesn’t allow users to copy or extract the contents. This option is available only for high (128-bit RC4 or AES) encryption.

9. **Click OK** when you have finished with the settings.
10. Take note of the information in the pop-up window, and then click **OK**.

11. Re-enter your password on the password confirmation window, and then click **OK**.

12. Click **OK** on the security information pop-up window.

13. A lock now appears in the **Navigation Pane** at the left of the screen, indicating that the form has been protected.

### 8.2 Viewing and Changing Security Settings

Once you save the form, security options go into effect. If you set a password to open the form, you can continue to edit the form until you close it. Then, when you reopen the form, you can continue editing as soon
as you enter the “open” password. However, if you checked the option to restrict editing of the form, you will need to remove this security and save the form again if you want to make further edits.

To change the security settings:

1. Click Tools → Protection.

![Protection Panel]

Figure 48 - Protection Panel

2. On the Protection Panel, click More Protection.

![More Protection Drop-Down List]

Figure 49 - More Protection Drop-Down List

To remove password security, click the Security Method drop-down and select No Security.
To make other security changes, click the Change Settings button.
4. Make the necessary changes in the Password Security Settings dialog box, and then click the OK button.

9. Enabling Usage Rights

In order to allow users of the form to save a copy of the form, along with the data that they have entered, you will need to “enable usage rights”. Enabling usage rights also allows the user to add comments and digitally sign the form.

Note: You should not enable usage rights until you have finished editing the form. Once you have enabled usage rights, certain editing functions are restricted, and you may need to make a copy of the form to make your changes.
To enable usage rights:

1. Click **File → Save As → Reader Extended PDF → Enable Additional Features**.

![Enable Usage Rights in Adobe Reader](image)

**Figure 51 - Enable Usage Rights Confirmation**

2. Click **Save Now** in the message window.

## 10. Distributing the Form and Collecting Form Responses

You can make the form available to users in several ways:

- Manually attach the form to an email message
- Upload the form to a website
- Use Adobe’s Distribute Form feature

**Note**: KSU’s licensing agreement with Adobe limits collecting responses from more than 500 recipients.

### 10.1 Distributing the Form by Email

If you know the email addresses of all the people who will use the form, you can distribute the form to the users by attaching it to an email message. Users can open the attachment, complete and save the form, and email the completed form back to you as an email attachment. **NOTE**: In order for users to be able to save the form with the data they have entered, you must have enabled usage rights on the form. See section 8 – *Enabling Usage Rights*.

### 10.2 Collecting Responses to an Emailed Form

When you receive the completed forms via email, you can collect the form responses manually, or, you can export the responses to a spreadsheet file. See section 11 on tracking responses.
When a user returns a completed form by manually attaching it to an email, the returned form may have the
same name as the original form, or, the user may have renamed it. When a user returns a completed form that
you added a “Submit” button to, the returned email will have the subject “Form Returned: formname.pdf”,
with the returned form attached. When you open the attachment, you will see the entire form.

10.3 Distributing the Form from a Website
If you need to make the form available to an unspecified group of users, you can upload the form to a website.
Users can download the form, complete and save the form, and then email the completed form back to you as
an email attachment. NOTE: In order for users to be able to save the form with the data they have entered,
you must have enabled usage rights on the form. See section 8 – Enabling Usage Rights.

10.4 Collecting Responses to a Downloaded Form
When you receive the completed forms via email, you can collect the form responses manually, or, you can
export the responses to a spreadsheet file. See section 11 on tracking responses.

When a user returns a completed form by manually attaching it to an email, the returned form may have the
same name as the original form, or, the user may have renamed it. When a user returns a completed form that
you added a “Submit” button to, the returned email will have the subject “Form Returned: formname.pdf”,
with the returned form attached. When you open the attachment, you will see the entire form.

10.5 Using the Distribute Form Wizard
The Acrobat Distribute Form Wizard gives you a selection of methods for distributing the form and collecting
form responses.

10.5.1 Using the “Manually Collect Responses in My Email Inbox” Option
This method allows you to distribute the form either by having Acrobat attach the form to an email, or, saving
the form and manually attaching it to an email later—or uploading it to your website. If Acrobat distributes the
form, Acrobat then sends the individual responses to your email inbox, and automatically collects the
responses in a master response file.

1. Click Tools → Forms → Distribute. The Distribute Form Wizard opens.
2. Click the drop-down box and select “Manually collect responses in my email inbox.”
3. Click Next.

4. Leave the Send it automatically using Adobe Acrobat radio button selected at the top of the Distribute Form dialog box.

**Note:** You must have Microsoft Outlook or another email client in order to use this option. Zimbra or another web-based email account alone will not work.
5. Click **Next**.

![Figure 54 - Distribute Form Wizard (Screen 3)](image)

6. Click the **To** button and locate the names of the people to whom you will send the form. You can also type the email addresses of recipients in the “To” box.

7. Enter a subject in the **Subject** box, or leave the default subject.

8. Type a new message in the **Message** box, or leave the default message. *Note that the message instructs the recipient to click Submit in Acrobat Reader to return the form. If the form contains a submit button, you may want to hide or remove it so as not to confuse users.*

9. Click **Send**. The form will be distributed to all recipients as an email attachment. A response file is automatically created and placed on your desktop, and the **Tracker** window opens. Tracker is covered in section 9.6.

When a user submits a completed form, you will receive an email with the subject “Submitting Completed Form”, with the returned form attached. To add the user’s responses to the response file that was created by the Distribution Wizard:

1. Click the attached file and open it. A dialog box will open on top of the file.
2. Click OK to add the responses to the existing response file. If you prefer, you can create a new response file (click Create a New Response File) and add the responses there.

### 10.5.2 Save a Copy of the Distributed Form

1. Click Tools → Forms → Distribute. The Distribute Form Wizard opens.

2. Click the drop-down box and select “Manually collect responses in my email inbox.”

3. Click Next.
4. Select the **Save a local copy and manually send it later** radio button at the top of the Distribute Form dialog box.

5. The **Specify where to save the file** prompt will appear. Browse to your desired file location, such as your desktop or documents.

6. Click **Finish**.

7. Your distributed form and response file will be created.
   a. The **distributed** form will have “_distributed.pdf” appended to the file name.
   b. The **response** file will have “_responses.pdf” appended to the file name.
   c. Your **original** form will maintain its file name.

   **NOTE: Keep all 3 versions of your PDF Form!**

8. The **Tracker** will open automatically. See Section 11 on Using Tracker, or close Tracker for now.

### 11. Using Tracker

Tracker allows you to view and edit the location of the response file, track which recipients have responded, add more recipients, email all recipients, and view the form responses.

1. Click **Tools → Forms → Track**. The **Tracker** window opens.
2. In the Tracker navigation pane, click Forms.

3. Click the Distributed link under the Forms heading.

4. Click the responses link for the appropriate form.

The window that opens contains information about the form, statistics about the responses, and links to perform various tasks.
To view the responses, click the **View Responses** link in the upper part of the window.

The **Welcome Page** lists the features that the response file provides. If you do not want to see the Welcome Page again, click the check box in the lower right corner.

Click the **Get Started** button to close the **Welcome Page** and view the responses window.
The Responses window shows responses to the form in a list, plus tools for working with the responses.

**Note:** You can open the response file for a distributed form without going through Tracker by just double-clicking on the response file icon for the form that was placed on your desktop.

### 11.1 Exporting Data from Returned Forms to a Spreadsheet

1. Click **Tools → Forms → More Form Options → Manage Form Data → Merge Data Files into Spreadsheet.**
2. On the **Export Data from Multiple Forms** dialog box, click the **Add Files** button.

![Figure 65 - File Selection Window]

3. Select one or more of the returned form files and click the **Open** button. **Note:** Each returned form must have a slightly different name.

4. Continue the processes until all files have been added and appear in the dialog box window.

5. Click the **Export** button. Acrobat will generate a CSV file.

6. Save the CSV file (rename if you like).

![Figure 66 - Export Progress Window]

The **Export Progress** window will indicate when the export is complete.
12. Accessibility

Acrobat X Pro has a number of tools for making PDF files accessible to people with visual or mobility impairments. However, according to the Adobe Acrobat X Accessibility Overview, “Creating an accessible PDF document directly from an authoring application is the best way to make PDF files accessible”.

For information on creating accessible PDF documents, please refer to the following Adobe websites:

http://www.adobe.com/accessibility/products/acrobat/overview.html