Microsoft Office
Access 2016 for Windows
Reports and Queries
# University Information Technology Services

Microsoft Office: Access 2016 for Windows

Reports and Queries

## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>4</td>
</tr>
<tr>
<td>Learning Objectives</td>
<td>4</td>
</tr>
<tr>
<td>Creating a Report</td>
<td>5</td>
</tr>
<tr>
<td>Adding Labels to a Report</td>
<td>8</td>
</tr>
<tr>
<td>Change Text Style and Color</td>
<td>9</td>
</tr>
<tr>
<td>Move and Resize a Text Box</td>
<td>9</td>
</tr>
<tr>
<td>Adding Fields to the Form</td>
<td>10</td>
</tr>
<tr>
<td>Arranging Fields on the Report</td>
<td>11</td>
</tr>
<tr>
<td>Adding Page Numbers to Your Report</td>
<td>13</td>
</tr>
<tr>
<td>Saving your Report</td>
<td>14</td>
</tr>
<tr>
<td>Viewing your report</td>
<td>15</td>
</tr>
<tr>
<td>Printing a Report</td>
<td>16</td>
</tr>
<tr>
<td>Creating Mailing Labels Using a Report</td>
<td>16</td>
</tr>
<tr>
<td>Placing Calculations on a Report</td>
<td>19</td>
</tr>
<tr>
<td>Adding a New Calculation Field to a Report</td>
<td>19</td>
</tr>
<tr>
<td>Using the Expression Builder to Create a Calculation</td>
<td>22</td>
</tr>
<tr>
<td>Creating Queries</td>
<td>23</td>
</tr>
<tr>
<td>Saving your Query</td>
<td>26</td>
</tr>
<tr>
<td>Including a Query in a Report</td>
<td>27</td>
</tr>
<tr>
<td>Importing an Excel File into Access</td>
<td>27</td>
</tr>
<tr>
<td>Additional Help</td>
<td>32</td>
</tr>
</tbody>
</table>
**Introduction**

*Microsoft Office Access 2016* allows people to effectively and efficiently organize data. This document has been developed to help you learn more about several useful features in Access including printing, applying queries, and importing *Excel* files. The various sections presented in this document will help you to build a solid knowledge foundation of the software.

The Microsoft Access Booklet Series will provide you the necessary knowledge on how to use *Microsoft Office Access 2016*. Before reading this booklet, it is recommended that you read the following Access 2016 documents on the UITS Documentation Center at [http://uits.kennesaw.edu/cdoc](http://uits.kennesaw.edu/cdoc):

- Microsoft Access 2016 – Intro to Access
- Microsoft Access 2016 – Intro to Forms
- Microsoft Access 2016 – Relational Databases and Subforms

**Learning Objectives**

The following objectives are covered in this document:

- Creating reports and labels.
- Placing calculations on reports.
- Using the query feature.
- Importing an Excel file.
Creating a Report

When you use a database, you typically use reports to view, format, and summarize data. The following explains how to create a report in Access.

1. From the Create tab, click Report Design.

![Creating a Report](image1)

2. You will be brought to the Report Design view. Right-click over the Page Header bar.

![Creating a Report](image2)


![Creating a Report](image3)
4. The following explains the different areas available in the *Report Design*.
   
a. **Report Header** – Text placed here will appear on the top of the first page of the report. For example, if there are ten pages in the report, the text would only appear at the top of the first page (See Figure 4).

b. **Page Header** – Text placed here will appear at the top of every page. Use this for column headings and page numbers (See Figure 4).

c. **Detail** – Text placed here will appear on every page (See Figure 4).

d. **Page Footer** – Text placed here will appear at the bottom of every page. Use this for footers and page numbers (See Figure 4).

e. **Report Footer** – Text placed here will appear at the bottom of the last page of the report. This is a perfect place to put an *End of Report* statement (See Figure 4).

![Figure 4 - Report Design](image)
5. You can resize different areas of the report sections. Hover your **mouse** over the *top* of a *section bar*. As you do this, a double-arrow will appear.

![Figure 5 - Adjusting the Size of Report Sections](image)

6. When you see the double-arrow, hold down the **mouse button** and move your mouse to make the section larger or smaller.

7. You can also adjust the width of the report. Hover your **mouse** over the *right edge* of the report. As you do this, a double-arrow will appear.

![Figure 6 - Adjusting the Width of the Report](image)

8. When you see the double-arrow, hold down the **mouse button** and move your mouse to make the report larger or smaller.
Adding Labels to a Report

Labels can be used to place text in the different areas of the report. Adding a label to your report is similar to adding one to a form. The following explains how to add a label to a report:

1. On the Design tab, in the Controls grouping, click Label.

![Figure 7 - The Label Button](image)

2. Your cursor icon will change to display the Label icon. Hold the left mouse button and drag to draw a text box on the form.

![Figure 8 - Drawing your Text Box](image)

3. Once finished drawing your text box, release the left mouse button. Your text box will appear.

4. Click in the text box and type your text.

![Figure 9 - Entering Text into the Text Box](image)
Change Text Style and Color
To change the text style and color of text:
1. Select the **text** you want to format.

![Selecting your Text](image)

**Figure 10 - Selecting your Text**

2. From the **Home** tab, the text can be formatted using the tools found in the **Text Formatting** grouping.

![Text Formatting Tools](image)

**Figure 11 - Text Formatting Tools**

Move and Resize a Text Box
The following explains how to move and resize a text box:
1. Click on the **text box** to select it.
2. Hover your mouse over the **side** of the text box. The cursor will turn to a **crosshair with arrows**.

![Hovering your Mouse to the Side of the Text Box](image)

**Figure 12 - Hovering your Mouse to the Side of the Text Box**

3. Hold left click and move the **text box** to the location of your choice on the form.
4. To re-size the text box, hover over a sizing handle, then hold left click and drag the **mouse** to resize the text box.

![Text Box Anchor Points](image)

**Figure 13 - Anchor Points on the Text Box**

### Adding Fields to the Form

In order to display data from your database in a report, you will need to add the fields from an existing table first. This process is similar to adding fields to a form. The following explains how to add fields to a report:

1. From the **Design** tab, click the **Add Existing Fields** button.

![Add Existing Fields](image)

**Figure 14 - Add Existing Fields**

2. The **Field List** window will appear. Click **Show all tables**.

![Show all tables](image)

**Figure 15 - Show all tables**

3. Click the + next to the table that contains the fields that you want to add to your form.

![Adding Fields](image)

**Figure 16 - Adding Fields**
4. A list of fields will be displayed. Left-click and hold on the first field you wish to add, then drag your mouse to the form.

![Figure 17 - Adding Fields](image)

5. When the field is over the form, release your mouse button and the field will be added to the form.

6. Repeat steps 4 and 5 until all desired fields have been added to your form.

**Arranging Fields on the Report**

Once the fields have been added from a table in your database, they will need to be arranged properly. The following instructions explain how to quickly arrange the fields on the report.

1. Select all of the fields that you want to arrange on the report by left-clicking and dragging your mouse cursor over all fields.

2. When you release the mouse button, all of the fields that were contained in the selection box will be selected.

3. From the Arrange tab, click Tabular.

![Figure 18 - Stacked Layout](image)
4. The selected fields will be arranged in a *Tabular layout*, with the labels appearing in your report header, and the fields lining up underneath.

![Figure 19 - Tabular Layout Applied to Fields](image)

5. From the *Arrange* tab, click **Remove Layout**.

![Figure 20 - Remove Layout Button](image)

6. The fields will be neatly arranged on the form. You can now move the fields around individually if you need to organize further.

7. Decrease the vertical space in the *Detail* section.

![Figure 21 - Adjust Vertical Section](image)

**Note:** The area displayed in the *detail* section will be displayed for each record in your report. A larger vertical area in the *Detail* section results in the records being further apart on the report.
Adding Page Numbers to Your Report

Adding page numbers to your report will help others track their position while reading through the data. The following explains how to add page numbers to a report:

1. From the *Design* tab, click **Page Numbers**.

![Figure 22 - Page Numbers](image)

2. The *Page Numbers* window will open. Under *Format*, select a **number format** (See Figure 23).
3. Under *Position*, select the **location** for the page numbers to be displayed (See Figure 23).
4. Under *Alignment*, select an **option** from the drop-down (See Figure 23).
5. Click **OK** (See Figure 23).

![Figure 23 - Page Numbers: Format](image)

6. Your *Page Numbers* will appear in the selected position.

![Figure 24 - Page Numbers Added to Footer](image)
Saving your Report

The following explains how to save the report.

1. Click the **File** tab.

![Figure 25 - File Tab](image)

2. The **backstage view** appears. Click **Save**.

![Figure 26 - Click Save](image)

3. The **Save As** window appears. Enter a **name** for the report and click the **OK** button.

![Figure 27 - Saving the Report](image)

**Note:** It may help you stay organized if you name the report the same name as the table that the report is associated with.
4. To close the report, click the X in the upper-right area of the report.

![Figure 28 - Closing the form](image)

**Viewing your report**

Once your report has been set up, you can view it at any time. If you add more records to your database, they will automatically be included on your report every time it is viewed. To view the report, simply open the report from under your *Access Objects* and the report will appear on your screen.

![Figure 29 - Report View](image)
Printing a Report

You can print out a copy of your report to present as a handout. All formatting that is present on the form will carry over to your printout. To print the report:

1. Under All Access Objects, select a report you wish to print.
2. From the Home tab, click File.
3. The backstage view will open. Click Print.
4. The Print options will display. Click Print.

5. The Print window will appear. Select a printer to print your report to, and click OK.
6. The report will be sent to the selected printer.

Creating Mailing Labels Using a Report

If you have a list of mailing addresses in your Access database, you can create a report that will generate labels based on the information found in your database. To create the mailing labels:

1. Select the table containing the data that you will use to create your labels.
2. From the Create tab, click Labels.

![Figure 32 - Labels](image1.png)

3. The Label Wizard window appears. Under Product Number, select the label code provided by the label manufacturer (e.g. Avery) and click Next.

![Figure 33 - Label Wizard](image2.png)

4. A list of formatting options will appear. Make any desired adjustments to the formatting options and click Next.

![Figure 34 - Formatting Options](image3.png)
5. A list of available fields from the selected table will display. Under Available Fields, select a field, then click the arrow button to move fields over to the Prototype label field.

![Figure 35 - Adding Fields to the Prototype Label](image)

6. Repeat step 5 until all desired fields have been added under Prototype Label. Click Next.

**Note:** When adding fields, be sure to account for spacing and punctuation between your fields. Fields added one after the other without spacing or punctuation will display all information from the table as one long string of text.

7. A list of available fields is displayed for you to sort your labels on. If you would like to sort the data, select a field under Available fields, then click the arrow to move the selected field in to the Sort by column.

![Figure 36 - Sorting Results](image)

8. Continue sorting fields until you are finished, then click Next.
9. In the next window, enter the name for the report and click the Finish button.

![Name Label Form]

**Figure 37 - Name Label Form**

10. The report will be created and saved under your list of Access Objects.

11. To print the labels, see the section Printing a Report.

### Placing Calculations on a Report

Reports can also be set up to display information that is not found on a table. For example, you could create a field that calculates the total sales between two days. The following sections will explain how to place a calculation on a report by first setting up the report with a new text box field for the total sales, then how to create the calculation.

### Adding a New Calculation Field to a Report

The following explains how to place a calculation on a report by first setting up an existing report with a new text box field for the total sales.

1. On the Design tab, click the Text Box.

![Text Box]

**Figure 38 - Text Box**
2. Draw a **text box** in the **Detail** section of the report.

![Figure 39 - Drawing a Text Box](image)

3. After entering the **text box**, click the **label** to select it.

![Figure 40 - Select the Label](image)

4. Right-click the **label**. A **context sensitive** menu will appear.
5. Click **Cut**.

![Figure 41 - Click Cut](image)

6. Right-click **inside** the **Page Header** section
7. Click **Paste**.

![Figure 42 - Paste the Label into the Page Header Section](image)
8. Drag the **label** over the corresponding text box in your form.

![Figure 43 - Align the Label with the Text Box](image)

9. Enter a **descriptive name** for the label.

![Figure 44 - Enter Total Sales into Label](image)

10. Select the **text box**.
11. From the **Design** tab, click **Property Sheet**.

![Figure 45 - Click Property Sheet](image)

12. On the **Property Sheet**, in the **Other** tab, enter a **descriptive name** in the **Name** field.

![Figure 46 - Enter a Name for the Text Box](image)
Using the Expression Builder to Create a Calculation

The following explains how to set-up the calculation on a report by using the Expression Builder.

1. On the Property Sheet, in the Data tab, click the ellipsis in the Control Source field.

![Figure 47 - Control Source](image)

2. The Expression Builder will open. In the Expression field, type = to begin a formula.

![Figure 48 - Expression Builder](image)

3. Enter the formula as [Day 1] + Day 2.

![Figure 49 - Enter the Formula](image)

4. Click OK to close the Expression Builder.
5. On the Property Sheet, in the Format tab, select Currency from the Format field.

![Property Sheet](image)

**Figure 50 - Select Currency for the Data Type**

6. The calculation has been created. You will see the new field and the results of your calculation when in the Report View.

<table>
<thead>
<tr>
<th>Store Number</th>
<th>Location</th>
<th>Day 1</th>
<th>Day 2</th>
<th>Total Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Sandy Spring</td>
<td>$20,000.00</td>
<td>$15,000.00</td>
<td>$35,000.00</td>
</tr>
<tr>
<td>3</td>
<td>Athens</td>
<td>$12,000.00</td>
<td>$18,000.00</td>
<td>$30,000.00</td>
</tr>
<tr>
<td>4</td>
<td>Kennesaw</td>
<td>$16,000.00</td>
<td>$17,000.00</td>
<td>$33,000.00</td>
</tr>
<tr>
<td>5</td>
<td>Atlanta-Midtown</td>
<td>$30,000.00</td>
<td>$25,000.00</td>
<td>$55,000.00</td>
</tr>
<tr>
<td>6</td>
<td>Atlanta-Candler Park</td>
<td>$24,000.00</td>
<td>$17,000.00</td>
<td>$41,000.00</td>
</tr>
</tbody>
</table>

**Figure 51 - Calculations for Total Sales Complete**

**Creating Queries**

Queries can be set-up to help you to search through a database for specific information, and then saved so they can be run multiple times. Some examples of items that can be searched for include:

- Stores with sales above or below an indicated amount
- Students earning an “A” in a specific course
- People who live in a specific zip code
- Companies located in a specific state
- Employees who have completed a First Aid course
The following explains how to create a query to search for stores in the database that had sales above $700 on the first day of a special sale that was held by the company.

1. From the Create tab, click **Query Design**.

2. The **Query Design** view will appear with the **Show Table** window, displaying a list of tables. Select the table that you want to add and click **Add**.

3. Click **Close**.

4. In the **Query Builder** at the bottom of the screen, place your cursor in the first column of the **Field** dropdown.

5. Click the **dropdown**, and select the field that you want included in this query.
6. Repeat steps 4-5 for the other columns, until you have all of the fields listed that you want included in this query.

![Figure 56 - Building Out the Query](image)

7. In the **Criteria** row, enter what you are **searching for** in the database under the **field** where you want to perform the search.

- For example, if you wanted to search for stores that had sales $700 and higher on day 1, you would enter the following in the sort row: \( \geq 700 \).

![Figure 57 - Entering Your Search Criteria](image)

8. From the **Design** tab, click **Run**.

![Figure 58 - Run the Query](image)

9. The results of your query will be displayed.

![Figure 59 - Query Results](image)
Saving your Query

The following explains how to save the query.

1. Click the **File** tab.

![Figure 60 - File Tab](image)

2. The **backstage view** appears. Click **Save**.

![Figure 61 - Click Save](image)

3. The **Save As** window appears. Enter a **name** for the query and click the **OK** button.

![Figure 62 - Saving the Form](image)

**Note:** Any data that is entered into the table after the query is saved will be included in the query if it meets the criteria specified.
Including a Query in a Report

The following explains how to include the results of a query in a report.

1. From the Create tab, click Report Design.

![Figure 63 - Report Design](image)

2. From the Design tab, click Property Sheet.
3. On the Data tab of the Property Sheet, click the drop-down arrow for Record Source.

![Figure 64 - Set Record Source](image)

4. A list of your tables and queries will display. Select your query from the list.
5. Proceed as normal designing the report. The data that appears on the report will come from the query that you selected.

Importing an Excel File into Access

If you already have data stored within an Excel spreadsheet, you can import that information into an existing table, or create a new table with the information. The following explains how to import data from an existing Excel spreadsheet and create a new table within Access.

1. From the External Data tab under the Import & Link grouping, click Excel.

![Figure 65 - Import Excel File](image)
2. The Import Spreadsheet Wizard will appear. Click **Browse**.

![Figure 66 - Browse for External Data](image)

3. The **File Explorer** will appear. Select the **Excel** file to import and click **Open**.
4. Select the **Import the source data into a new table in the current database** option.

![Figure 67 - Import the Source Data into a New Table](image)

5. Click **OK**.

![Image](image)
6. If the Excel file contains multiple **spreadsheets**, select the **spreadsheet** and click **Next**. **Note**: If your Excel file only has one spreadsheet, then skip to step 7.

![Multiple Spreadsheets Available](image)

**Figure 68 - Multiple Spreadsheets Available**

7. The **wizard** will ask you if the first row of your spreadsheet contains column headings. If yes, check the box next to **First Row Contains Column Headings**.

![First Row Contains Column Headings](image)

**Figure 69 - First Row Contains Column Headings**

8. Click **Next**.
9. For the next step of the import wizard, you can select the different columns and adjust the **Field Name** and **Data Type** for the database.

![Figure 70 - Adjust Field Options](image)

10. When you are finished, click **Next**.

11. Determine if you want Access to create a primary key for you, if you want to choose your own primary key from data within the spreadsheet, or if you don’t want a primary key.

![Figure 71 - Add Primary Key](image)

12. Click **Next**.
13. The wizard will ask you to enter a name for the **new table** in the *Import to Table* field.

![Figure 72 - Import to Table](image)

14. Click **Finish**.

15. The *Save Import Steps* window will appear. Select **Save Import Steps** if you wish to save the import steps. Doing so will allow you to quickly repeat the operation.

![Figure 73 - Save Import Steps](image)

16. Click **Close**
17. The information in Excel will be imported into Access. At this point, you can create forms, create reports, create queries, etc.

![Customer Information Table](image)

Figure 74 - New Table Imported

### Additional Help

For additional support, please contact the KSU Service Desk:

**KSU Service Desk for Faculty & Staff**
- Phone: 470-578-6999
- Email: service@kennesaw.edu
- Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)

**KSU Student Helpdesk**
- Phone: 470-578-3555
- Email: studenthelpdesk@kennesaw.edu
- Website: [http://uits.kennesaw.edu](http://uits.kennesaw.edu)